Falco Cloud CloudTrail event processing and rule evaluation are now operating normally.
A fix has been deployed, and we have confirmed that services are functioning as expected.
We have continued monitoring and confirmed stability across the system.
Thank you for your patience and understanding.
Posted Apr 14, 2026 - 22:56 UTC
Monitoring
A fix has been deployed, and the issue has been mitigated. Event processing is returning to normal, with delays and potential detection gaps recovering. We are continuing to monitor recovery to ensure all services are fully operating as expected. Further updates will be shared as needed.
Posted Apr 14, 2026 - 21:29 UTC
Investigating
We are currently investigating an issue affecting CloudTrail Threat detection. Due to this issue, some customers may experience delays in event processing. Ultimately, this may also turn result in missed detections or dropped logs. The issue has been identified as related to a recent managed rules deployment conflicting with the detection engine, and we are actively working on reverting the change to restore normal operation. We will provide further updates as more information becomes available.